Classroom Spy Pro · デスクトップ版ガイド

教室監視ソフトウェアコンソール

このページの内容

ドキュメント

コンソールでの生徒のコンピュータの追加

生徒のコンピューターを監視できるようにするには、まず生徒のコンピューターをコンソールに追加する必要があります。 次の 4 つの方法でコンピュータを追加できます。

使用 File コンピューターを追加するための メニュー:

監視オプション

コンピュータを手動で追加する

から「コンピュータを追加...」を選択します。 File メニュー:

ダイアログには 2 つのタブがあります。

  • 基本オプション
  • 詳細オプション

Basic Options

監視するコンピュータを追加します

パラメータ:

Remote computer (host or IP):

生徒のコンピュータのネットワーク ホスト名または IP を入力します。 ローカル ネットワーク上で DHCP を使用する場合は、コンピュータ名を入力する必要があります。

Nickname:

生徒のコンピュータを簡単に識別できるように表示する名前を入力します。

Agent’ password:

このフィールドには、エージェントのインストール時に使用したものと同じパスワードを入力します。

Connection Type:

直結接続

管理コンソールとエージェントの間で直接 TCP/IP 接続を使用します。 コンソールはクライアントとして機能し、エージェントはサーバーとして機能します。 直接接続は、たとえば、すべてのコンピュータが同じネットワーク上にある場合、またはサブネットワーク間で適切なルーティングが構成されている場合に機能します。 使用するポート (デフォルトの TCP 5444) が通信用に有効になっている必要があります。

逆接続

管理コンソールとエージェントの間で直接 TCP/IP 接続を使用します。 コンソールはサーバーのように機能し、エージェントはクライアントとして機能します。 逆接続は、すべてのコンピュータが同じネットワーク上にある場合、またはサブネットワーク間で適切なルーティングが設定されている場合などに機能します。 コンソールで「コンソール逆接続サーバー」を有効にする必要があります。 エージェントが接続するコンソールのホスト名または IP を指定する必要があります。 使用するポート (デフォルトでは TCP 444) が通信用に有効になっている必要があります。

クラウド接続

[クラウド接続を使用する] を選択すると、クラウド接続経由でもこのコンピューターにアクセスできるようになり、インターネット経由でコンピューターを監視できるようになります。

クラウド ライセンスはサブスクリプション ベースです。 クラウドへのインストールについて詳しくは、こちらをご覧ください。

 

Advanced Options

監視するコンピュータを構成します

パラメータ:

TCP Port:

このフィールドには、エージェントのインストール時に使用したのと同じポートを入力します。 デフォルトのポートは 5444 です。

Connection security:

選択してください Auto (最初に TLS を試行し、エージェントが TLS でまったく応答しない場合にのみエンドツーエンド暗号化にフォールバックします)、または強制 End-to-end encryption または TLS はエージェント独自の設定と一致します。 TLS が使用される場合、コンソールは最初の接続時に証明書のフィンガープリントを記憶 (「ピン留め」) し、その後の接続のたびにそれをチェックします。 ある Forget ボタンは、固定されたフィンガープリントをクリアします (たとえば、新しい証明書を使用してエージェントを再インストールした後)。 コンソールが新しい証明書を自動的に信頼するのではなく、承認のために保持するように設定されている場合 (「 Configuration / General)、承認待ちの証明書もここに表示されます。 Trust... ボタンをクリックして、指紋を確認して確認します。

Connect automatically:

「Classroom Spy Professional Console」の起動時に生徒のコンピュータを自動的に接続する場合は、このチェックボックスをオンにします。

Monitor :

サムネイルとして表示するモニターを選択します。

Multisession - terminal (TS, RDP) options :

コンピューターが RDP、TS サーバーである場合に選択します。 これにより、すべてのリモート セッションを表示できるようになります。

Account filter

を開く Account filter [] タブで、このコンピュータ上のどの Windows ユーザー アカウントを監視するかを選択します。

選択してください "Monitor all accounts except selected" リストしたアカウントを除くすべてのアカウントを監視する (例: 「管理者」を除外する)、または "Monitor only selected accounts" は、リストしたアカウントのみを監視します。 アカウント名を入力してクリックします Add をリストに追加するには、エントリを選択して、 Remove を削除してください。

フィルターはセッションごとに適用されるため、コンピューターがターミナル サーバー (TS、RDP) であり、複数の学生が同時にログインしている場合にもフィルターは正しく機能します。各セッションのアカウントはフィルターに対して個別にチェックされ、監視されていないアカウントは単にコンソールに表示されません。

クラウドからコンピュータを追加

を使用して生徒のコンピュータにエージェントをインストールした場合 Cloud Connection 「」と入力すると、これらのコンピュータをコンソールに追加できるようになります。

を作成したことを確認してください。 Cloud account。 クラウド アカウントは、エージェントのインストール中、またはメニュー「」を使用して作成できます。 Cloud / Create cloud account...".

クラウド監視の構成

クラウド接続を使用した監視の詳細については、ここをクリックしてください。

すでに作成されている場合 Cloud account メニュー「」を使用して、このクラウド アカウントのログイン情報をコンソールに入力できます。 Cloud / Configure cloud connection":

クラウド経由の監視の構成

その後、メニュー「 Cloud / Add computers from Cloud" を使用して、すでにクラウドに追加されているコンピューターを追加します。

クラウドからコンピュータを追加する場合、エージェントのパスワード (生徒のコンピュータにエージェントをインストールして入力したパスワード) を入力する必要があります。

インストールされているエージェントのネットワークをスキャンします

ネットワーク コンピュータのスキャン

生徒のコンピュータにエージェントをすでにインストールしている場合は、ネットワークをスキャンしてエージェントを自動的に追加できます。 スキャンでは、事前に接続タイプを選択する必要はありません。すべてのアドレスに対して最初に TLS を試行し、アドレスが積極的に応答するが TLS を拒否した場合にのみエンドツーエンド暗号化にフォールバックするため、どちらかのモードを使用しているエージェントは追加の設定なしで検出されます。

ネットワーク アダプタと IPv4 範囲を選択し、エージェントのパスワードとポートを入力して、[クリック] をクリックします。 Scan。 クリック Stop : アクティブなスキャンを停止します。

FAQ: スキャン用のデフォルトのネットワーク アダプターを設定するにはどうすればよいですか?

開く File / Configuration...。 で General タブで、必要なアダプターを選択します。 Default network adapter をクリックしてください OK。 それぞれ新しい Scan network for computers... ダイアログはこのアダプターを選択します。 使用できない場合は、最初のアクティブなアダプターが選択されます。 構成されたデフォルトを変更せずに、現在のスキャンに別のアダプターを選択できます。

結果には、ホスト名、IP アドレス、およびパスワードのステータスが表示されます。 パスワードが正しければ、 OS には、報告されたオペレーティング システムとそのアイコンが表示されます。 Agent version は、報告されたエージェントのバージョンを示します。 これらの詳細は、利用可能な場合にのみ表示されます。 個別の OS バージョン列や不明な値のプレースホルダーはありません。

Show only computers not yet added はデフォルトでオフになっているため、検出されたすべてのコンピュータが表示されます。 ホスト名または IP アドレスがすでにコンソールにあるコンピュータを非表示にするには、これをオンにします。 再度表示するにはクリアしてください。

使用 Select all または Unselect all : 現在表示されている結果のチェックボックスを変更します。 個々の選択は、さらに結果が到着するときやフィルターが変更されるときにも保持されます。 Add は、チェックされた表示可能なコンピュータのみを追加します。 列は最も幅の広いエントリに自動的に適合します。

コンピューター内 Properties、OS アイコンは、報告されたオペレーティング システム名のすぐ左側にあります。 エージェントのバージョンは利用可能な場合に表示されます。 古いエージェントが Windows 11 コンピューター上で Windows 10 を報告する場合は、エージェントを更新し、再接続またはスキャンを再度行ってください。

LAN コンピュータのグループを追加

LAN 上のコンピュータを監視する

LAN 上にコンピュータを自動的に追加できます。 LAN で許可されている場合 (NT DOMAIN 管理者など)、エージェントをリモートでインストールできます。

Show only computers not yet added チェックボックスは、 Add group of LAN computers。 デフォルトではチェックされていません。 すでにコンソールに追加されているコンピュータ名を非表示にするには、これをオンにします。

学生用コンピュータリスト

リスト

Student Computers List には、追加されたすべてのコンピューターが表示されます。 コンピュータのアイコンには、生徒のコンピュータの状態が表示されます。

いくつかのシステム コマンドには、 Object Menu。マウスの右クリックで呼び出すことができます。

コンピュータはグループに編成できます - 「」を使用します。 Add computer group..." から File メニュー。

コンピュータ グループを右クリックし、 "Filter by this group on Remote Screens" オブジェクト メニューから を選択すると、 Remote Screens タブをそのグループに追加 - これは、[リモート画面] タブのグループ フィルター ドロップダウンを使用して設定できる同じフィルターです。

デフォルトでは、コンソールの起動時にすべてのコンピュータ グループが展開されます。 これは「」を使用して変更できます。 Configuration..." から File メニュー、タブ General、「」のチェックを外します。 Expand groups when console starts".

同じ General タブには「Automatically trust a computer's certificate the first time it connects over TLS"、デフォルトでチェックされています。チェックを外すと、新しいコンピュータの証明書を自動的に信頼するのではなく、承認のために保持します - を参照してください。 Connection security 上記の。

コンピューターのインポートおよびエクスポート (CSV、タブ区切り、Excel)

コンピューターとグループは、CSV、タブ区切りテキスト、または Microsoft Excel (.xlsx) ファイルに一括エクスポートして、インポートし直すことができます。 選択してください "Export Computers to File..." および "Import Computers from File..." から File メニューを選択するか、コンピュータ グループ (またはすべてを含めるにはリストの空の領域) を右クリックし、リストから同じコマンドを選択します。 Object Menu。 ファイルは UTF-8 として読み書きされます。

エクスポートするときは、「保存」ダイアログでファイルの種類を直接選択します。 CSV (Comma delimited), CSV (Semicolon delimited), Tab Delimited Text、または Microsoft Excel。 インポート時に、CSV またはタブ区切りファイルの区切り文字が自動的に検出されます。

エクスポートされたファイルでは、以下の列順序が使用されます。 ヘッダー行が同じ列名を保持している限り、インポート時に列を並べ替えることができます。 認識されない列は無視され、空のままの列には以下に示すデフォルトが使用されます。 host は必須です:

カラム説明空の場合のデフォルト
groupコンピューターのグループ パス (例: /研究室1/A室。 欠落しているグループはインポート時に自動的に作成されます。Root (/)
nameコンソールに表示される表示名(ニックネーム)。Falls back to host
hostリモート コンピューターの IP アドレスまたはホスト名。Required - row is skipped if empty
portエージェント接続ポート。Default agent port
passwordエージェント接続パスワード。See note below - never exported
connection_typeダイレクト、リバース、クラウド、またはカンマ区切りの組み合わせ。Direct
auto_connectYes または No - 起動時にコンソールが自動的に接続するかどうか。Yes
multisession自動、単一、または複数。Automatic
hwidエージェントのクラウド登録のハードウェア ID。Required to auto-connect a Cloud entry; see note below

password 列はエクスポート時に常に空のままになります。パスワードがファイルに書き込まれることはありません。 インポート時に、共通のパスワードを 1 回入力でき、パスワード列が空のすべての行に使用されます。 独自のパスワード値を持つ行では、代わりにその値が使用されます。

connection_typeにCloudを含むコンピューターでは、AgentのCloud登録を識別するhwidも指定してください。空欄にした場合は、インポートしたコンピューターのPropertiesを開き、Use Cloud connectionを再度有効にします。Cloudアカウントから対応するコンピューターを選択し、再接続してください。

信頼を変更する前に TLS 証明書を検証してください

コンソールの固定または保留中のフィンガープリントと、エージェントによって表示される証明書のフィンガープリントを比較します。 Connection Security。 独立して信頼できるチャネルを通じてエージェントのフィンガープリントを取得します。 アドレスが一致したり、見慣れたコンピューター名が表示されたりするだけでは、証明書が変更されたことを確認するのに十分ではありません。

フィンガープリントが予期せず変更された場合は、停止して管理者に調査してもらいます。 正規のエージェントの再インストール/証明書の置き換えが確認された後、次のコマンドを使用して古い PIN をクリアします。 Forget デスクトップ コンピューターのプロパティで を入力し、再接続し、新しいフィンガープリントを比較して使用します。 Trust... 承認が必要な場合は 。 次の最初の接続の信頼設定を確認します。 Configuration / General。 参照 エージェントのセキュリティ構成.

例: 2 台の教室用コンピューターをインポートします

この例示的な UTF-8 CSV は、文書化された 9 列のインポーター形式に従っています。 予約されたサンプルのホスト名を使用し、パスワードを空のままにし、 auto_connect から Noなので、インポートしても接続は試行されません。 使用する前に、ホスト名をアクセス可能な許可されたコンピュータに置き換えてください。

group,name,host,port,password,connection_type,auto_connect,multisession,hwid
/Lab A,Student 01,lab-pc-01.school.example,5444,,Direct,No,Single,
/Lab A,Student 02,lab-pc-02.school.example,5444,,Direct,No,Single,

サンプル CSV をダウンロードする。 選択してください File / Import Computers from File... 目的の親グループで「」を選択し、プロンプトが表示されたら共通エージェントのパスワードを入力します。 空のパスワードフィールドには共通のパスワードが使用されます。 エクスポートにはパスワードが含まれることはありません。

Lab A
  Student 01 → lab-pc-01.school.example
  Student 02 → lab-pc-02.school.example

上記のツリーは、キャプチャされた結果ではなく、空のルートにインポートするために予期される構造です。 新しいエントリ、ポート、および Direct 接続前のモード。 クラウド行の場合は、実際の登録を使用します hwid; ホスト名だけではクラウド登録を識別しません。 参照 接続エラー, アカウントのフィルタリング および RDP セッションのセットアップ.

ページの先頭へ