Classroom Spy Pro · Guida desktop

Console software di monitoraggio della classe

In questa pagina

Documentazione

Aggiunta di computer studente nella console

Per poter monitorare i computer studente, è necessario prima aggiungerli alla console. Puoi aggiungere computer in quattro modi:

Utilizzare File Menu per aggiungere computer:

Opzioni di monitoraggio

Aggiungi computer manualmente

Selezionare "Aggiungi computer..." da File Menù :

La finestra di dialogo ha due schede:

  • Opzioni di base
  • Opzioni avanzate

Basic Options

Aggiungi il computer che desideri monitorare

Parametri:

Remote computer (host or IP):

Immettere il nome host di rete o l'IP del computer studente. Quando si utilizza DHCP sulla rete locale è necessario inserire il nome del computer.

Nickname:

Immettere il nome che si desidera venga visualizzato per identificare facilmente il computer studente.

Agent’ password:

In questo campo, inserire la stessa password utilizzata durante l'installazione dell'agente.

Connection Type:

Connessione diretta

Utilizza una connessione TCP/IP diretta tra la console di amministrazione e gli agenti. La console funge da client e l'agente da server. La connessione diretta funziona, ad esempio, se tutti i computer si trovano sulla stessa rete o se è configurato il routing corretto tra le sottoreti. La porta utilizzata (TCP 5444 predefinita) deve essere abilitata per la comunicazione.

Connessione inversa

Utilizza una connessione TCP/IP diretta tra la console di amministrazione e gli agenti. La console agisce come un server e l'agente come un client. La connessione inversa funziona, ad esempio, se tutti i computer si trovano sulla stessa rete o se è configurato il routing corretto tra le sottoreti. È necessario abilitare "Server connessione inversa console" nella console. È necessario specificare il nome host o l'IP della console a cui si connetterà l'agente. La porta utilizzata (TCP 444 predefinita) deve essere abilitata per la comunicazione.

Connessione al cloud

È possibile scegliere di rendere questo computer accessibile anche tramite connessione Cloud selezionando "Utilizza connessione Cloud" che consente di monitorare il computer tramite Internet.

La licenza cloud è basata su abbonamento. Ulteriori informazioni sull'installazione nel Cloud.

 

Advanced Options

Configurare il computer che si desidera monitorare

Parametri:

TCP Port:

In questo campo, inserire la stessa porta utilizzata durante l'installazione dell'agente. La porta predefinita è 5444.

Connection security:

Scegli Auto (prova prima TLS, torna alla crittografia end-to-end solo se l'agente non risponde affatto con TLS) o forza End-to-end encryption o TLS in modo che corrisponda all'impostazione dell'agente. Quando viene utilizzato TLS, la console ricorda ("pin") l'impronta digitale del certificato la prima volta che si connette e la controlla ad ogni connessione successiva; un Forget Il pulsante cancella un'impronta digitale bloccata (ad esempio dopo aver reinstallato un agente con un nuovo certificato). Se la console è impostata per conservare i nuovi certificati per l'approvazione invece di considerarli attendibili automaticamente (vedere Configuration / General), anche qui viene mostrato un certificato in attesa di approvazione, con a Trust... Pulsante per rivedere la sua impronta digitale e confermarla.

Connect automatically:

Selezionare questa casella di controllo se il computer studente deve essere connesso automaticamente all'avvio di "Classroom Spy Professional Console".

Monitor :

Selezionare quale monitor verrà visualizzato come miniatura.

Multisession - terminal (TS, RDP) options :

Selezionare se il computer è un server RDP o TS. Ciò ti consentirà di vedere tutte le sessioni remote.

Account filter

Apri il Account filter Scheda per scegliere quali account utente Windows su questo computer vengono monitorati.

Scegli "Monitor all accounts except selected" per monitorare tutti gli account tranne quelli elencati (ad esempio escludere "Amministratore"), oppure "Monitor only selected accounts" per monitorare solo gli account elencati. Digitare un nome account e fare clic Add per aggiungerlo all'elenco, selezionare una voce e fare clic Remove per rimuoverlo.

Il filtro viene applicato per sessione, quindi funziona correttamente anche quando il computer è un server terminal (TS, RDP) con diversi studenti che accedono contemporaneamente: l'account di ciascuna sessione viene confrontato con il filtro in modo indipendente e gli account non monitorati semplicemente non vengono visualizzati nella console.

Aggiungi computer dal cloud

Se hai installato l'agente sui computer degli studenti utilizzando Cloud Connection , ora puoi aggiungere quei computer alla console.

Assicurati di aver creato Cloud account. L'account cloud può essere creato durante l'installazione dell'agente o utilizzando il menu " Cloud / Create cloud account...".

Configura monitoraggio cloud

Fare clic qui per ulteriori informazioni sul monitoraggio tramite connessione cloud.

Se hai già creato Cloud account sarà quindi possibile inserire le informazioni di accesso all'account Cloud nella console utilizzando il menu " Cloud / Configure cloud connection":

Configurare il monitoraggio tramite cloud

Successivamente è possibile utilizzare il menu " Cloud / Add computers from Cloud" per aggiungere i computer già aggiunti al Cloud.

Quando si aggiungono computer dal Cloud, è necessario inserire la password dell'agente (la password inserita utilizzando l'installazione dell'agente sul computer dello studente)

Scansione rete per agenti installati

Scansione dei computer di rete

Se hai già installato gli agenti sui computer degli studenti, puoi scansionare la rete e aggiungerli automaticamente. La scansione non richiede la scelta anticipata di un tipo di connessione: prova prima TLS per ogni indirizzo e ricorre alla crittografia end-to-end solo quando un indirizzo risponde attivamente ma rifiuta TLS, quindi gli agenti che utilizzano entrambe le modalità vengono trovati senza ulteriore configurazione.

Scegli l'adattatore di rete e l'intervallo IPv4, inserisci la password e la porta dell'agente, quindi fai clic su Scan. Fare clic Stop per interrompere una scansione attiva.

Domande frequenti: come posso impostare l'adattatore di rete predefinito per le scansioni?

Apri File / Configuration.... Su General Nella scheda , selezionare l'adattatore richiesto in Default network adapter e fare clic OK. Ogni nuovo Scan network for computers... La finestra di dialogo seleziona questo adattatore. Se non è disponibile, viene selezionato il primo adattatore attivo. È possibile scegliere un altro adattatore per la scansione corrente senza modificare l'impostazione predefinita configurata.

I risultati mostrano il nome host, l'indirizzo IP e lo stato della password. Quando la password è corretta, OS mostra il sistema operativo segnalato con la sua icona, e Agent version mostra la versione dell'agente segnalata. Questi dettagli vengono visualizzati solo quando disponibili; non esiste una colonna separata della versione del sistema operativo o un segnaposto con valore sconosciuto.

Show only computers not yet added è deselezionato per impostazione predefinita, quindi vengono visualizzati tutti i computer rilevati. Selezionalo per nascondere i computer il cui nome host o indirizzo IP è già presente nella console. Cancellalo per mostrarli di nuovo.

Utilizzare Select all o Unselect all per modificare le caselle di controllo per i risultati attualmente visibili. Le scelte individuali vengono preservate man mano che arrivano più risultati e quando il filtro cambia. Add aggiunge solo i computer visibili e selezionati. Le colonne si adattano automaticamente alla voce più ampia.

Nel computer Properties, l'icona del sistema operativo si trova immediatamente a sinistra del nome del sistema operativo riportato; la versione dell'agente viene mostrata quando disponibile. Se un agente precedente segnala Windows 10 su un computer Windows 11, aggiornare l'agente e riconnettersi o eseguire nuovamente la scansione.

Aggiungi gruppo di computer LAN

Monitorare i computer sulla LAN

È possibile aggiungere automaticamente computer alla LAN. L'agente può essere installato in remoto se la tua LAN lo consente (ad esempio se sei un amministratore del DOMINIO NT).

Il Show only computers not yet added La casella di controllo è disponibile anche in Add group of LAN computers. Per impostazione predefinita è deselezionato; selezionalo per nascondere i nomi dei computer già aggiunti alla console.

Elenco computer degli studenti

Elenco

Il Student Computers List visualizza tutti i computer aggiunti. L'icona del computer mostra lo stato del computer studente.

È possibile accedere facilmente a diversi comandi di sistema utilizzando il Object Menu, che può essere richiamato facendo clic con il pulsante destro del mouse.

I computer possono essere organizzati in gruppi: utilizzare " Add computer group..."da File Menù .

Fare clic con il pulsante destro del mouse su un gruppo di computer e selezionare "Filter by this group on Remote Screens" dal menu Oggetto per filtrare istantaneamente i file Remote Screens scheda a quel gruppo: si tratta dello stesso filtro che è possibile impostare anche utilizzando il menu a discesa del filtro di gruppo nella scheda Schermate remote.

Per impostazione predefinita, tutti i gruppi di computer vengono espansi all'avvio della console. Puoi modificarlo utilizzando " Configuration..."da File Menù , tab General, deselezionando " Expand groups when console starts".

Lo stesso General La scheda contiene "Automatically trust a computer's certificate the first time it connects over TLS", selezionato per impostazione predefinita. Deselezionalo per conservare il certificato di un nuovo computer per la tua approvazione invece di fidarlo automaticamente - vedi Connection security sopra.

Importazione ed esportazione di computer (CSV, delimitato da tabulazioni, Excel)

I computer e i gruppi possono essere esportati in blocco in un file CSV, testo delimitato da tabulazioni o file Microsoft Excel (.xlsx) e reimportati. Scegli "Export Computers to File..." e "Import Computers from File..." dal File oppure fare clic con il pulsante destro del mouse su un gruppo di computer (o su un'area vuota dell'elenco per includere tutto) e scegliere gli stessi comandi dal Object Menu. I file vengono letti e scritti come UTF-8.

Durante l'esportazione, seleziona il tipo di file direttamente nella finestra di dialogo Salva: CSV (Comma delimited), CSV (Semicolon delimited), Tab Delimited Texto Microsoft Excel. Al momento dell'importazione, il delimitatore di un file CSV o delimitato da tabulazioni viene rilevato automaticamente.

Il file esportato utilizza l'ordine delle colonne riportato di seguito. Le colonne possono essere riordinate durante l'importazione purché la riga di intestazione mantenga gli stessi nomi di colonna; le colonne non riconosciute vengono ignorate e una colonna lasciata vuota utilizza solo il valore predefinito mostrato di seguito host è richiesto:

ColonnaDescrizionePredefinito quando vuoto
groupPercorso di gruppo del computer, ad es. /Lab1/StanzaA. I gruppi mancanti vengono creati automaticamente durante l'importazione.Root (/)
nameNome visualizzato (nickname) mostrato nella console.Falls back to host
hostIndirizzo IP o nome host del computer remoto.Required - row is skipped if empty
portPorta di connessione dell'agente.Default agent port
passwordPassword di connessione dell'agente.See note below - never exported
connection_typeDiretto, Inverso, Cloud o una combinazione separata da virgole.Direct
auto_connectSì o No: indica se la console si connette automaticamente all'avvio.Yes
multisessionAutomatico, Singolo o Multiplo.Automatic
hwidID hardware della registrazione Cloud dell'agente.Required to auto-connect a Cloud entry; see note below

Il password La colonna viene sempre lasciata vuota durante l'esportazione: le password non vengono mai scritte nel file. Durante l'importazione, è possibile immettere una password comune una volta e utilizzarla per ogni riga la cui colonna password è vuota; una riga con il proprio valore di password utilizza invece quel valore.

Per un computer il cui connection_type include Cloud, hwid Dovrebbe essere fornito anche : identifica la registrazione nel cloud dell'agente. Se è lasciato vuoto, apri le Proprietà del computer importato e riattivalo Use Cloud connection per selezionare il computer corrispondente dal tuo account Cloud e riconnetterlo.

Verificare un certificato TLS prima di modificare l'attendibilità

Confrontare l'impronta digitale bloccata o in sospeso della console con l'impronta digitale del certificato mostrata dall'agente in Connection Security. Ottieni l'impronta digitale dell'agente attraverso un canale affidabile e indipendente. La corrispondenza di un indirizzo o la visualizzazione di un nome di computer familiare non è sufficiente per verificare un certificato modificato.

Se un'impronta digitale cambia inaspettatamente, interrompere e chiedere all'amministratore di indagare. Dopo aver verificato la reinstallazione/sostituzione del certificato di un agente legittimo, cancellare il vecchio pin con Forget nelle proprietà del computer desktop, riconnettersi, confrontare la nuova impronta digitale e utilizzare Trust... se è richiesta l'approvazione. Esaminare l'impostazione di attendibilità della prima connessione in Configuration / General. Vedi Configurazione della sicurezza dell'agente.

Esempio: importare due computer della classe

Questo CSV UTF-8 illustrativo segue il formato di importazione documentato a nove colonne. Utilizza nomi host di esempio riservati, lascia le password vuote e imposta auto_connect a No, quindi l'importazione non tenta le connessioni. Sostituire i nomi host con i computer raggiungibili autorizzati prima dell'uso.

group,name,host,port,password,connection_type,auto_connect,multisession,hwid
/Lab A,Student 01,lab-pc-01.school.example,5444,,Direct,No,Single,
/Lab A,Student 02,lab-pc-02.school.example,5444,,Direct,No,Single,

Scarica il CSV di esempio. Scegli File / Import Computers from File... nel gruppo principale desiderato e immettere la password comune dell'agente quando richiesto. I campi password vuoti utilizzano quella password comune; le esportazioni non includono mai le password.

Lab A
  Student 01 → lab-pc-01.school.example
  Student 02 → lab-pc-02.school.example

L'albero sopra è la struttura prevista per l'importazione in una radice vuota, non un risultato acquisito. Esaminare le nuove voci, port e Direct Modalità prima della connessione. Per una riga Cloud, utilizzare la registrazione effettiva hwid; un nome host da solo non identifica una registrazione al Cloud. Vedi Errori di connessione, filtraggio account e Configurazione della sessione RDP.

Torna in alto